On this page

Symptoms

PrivateWave stops working and does connect anymore. Forcing a reconnection (kill app and restart) does not solve the issue.

Cause

On recent version of iOS (5.x), depending on mobile network and iOS version, iPhone completely lose connectivity to internet.

Despite it report good signal and positive connection, data connection is broken. To verify if this is the case, open Safari browser and try to open some websites. It connection times out, data connection broke. 

Workaround

  1. Enable airplane mode
  2. Wait 10 seconds
  3. Disable airplane mode
  4. Check that Safari can browse internet
  5. Force PrivateWave reconnection

Resolution

N/A. Waiting for iOS fix from Apple